summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2007-04-10 17:13:38 +0000
committerSimon Josefsson <simon@josefsson.org>2007-04-10 17:13:38 +0000
commit98b41c3aa4d2d2d4b7ba82c09ab02b001c11efc1 (patch)
tree5e270df8c4e224dc4dfc0edb73866132ee4eb69a /configure.in
parent407ca9fdb24735dda0c5434b05a70c41be76cd63 (diff)
downloadgnutls-98b41c3aa4d2d2d4b7ba82c09ab02b001c11efc1.tar.gz
Fix --disable-*.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 467463e2d8..beaca9f74e 100644
--- a/configure.in
+++ b/configure.in
@@ -312,20 +312,20 @@ else
ac_full=0
AC_MSG_RESULT(yes)
fi
+AM_CONDITIONAL(ENABLE_SRP, test "$ac_enable_srp" != "no")
AC_MSG_CHECKING([whether to disable PSK authentication support])
AC_ARG_ENABLE(psk-authentication,
AS_HELP_STRING([--disable-psk-authentication],
[disable the PSK authentication support]),
- ac_enable_srp=no)
-if test x$ac_enable_srp != xno; then
+ ac_enable_psk=no)
+if test x$ac_enable_psk != xno; then
AC_MSG_RESULT(no)
AC_DEFINE(ENABLE_PSK, 1, [enable PSK authentication])
else
ac_full=0
AC_MSG_RESULT(yes)
fi
-AM_CONDITIONAL(ENABLE_SRP, test "$ac_enable_srp" != "no")
AC_MSG_CHECKING([whether to disable anonymous authentication support])
AC_ARG_ENABLE(anon-authentication,
@@ -352,6 +352,7 @@ else
ac_full=0
AC_MSG_RESULT(yes)
fi
+AM_CONDITIONAL(ENABLE_AUTHZ, test "$ac_enable_authz" != "no")
AC_MSG_CHECKING([whether to disable extra PKI stuff])
AC_ARG_ENABLE(extra-pki,