summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2007-09-24 12:39:58 +0200
committerSimon Josefsson <simon@josefsson.org>2007-09-24 12:39:58 +0200
commit3e36432062f6a1a1758a13591aed7951d4081a30 (patch)
treec79fec7a1692bbd9259bf974220617607cb04793 /configure.in
parent4f1a8ab89e804066e54dce364b15f00d9c2e3f30 (diff)
downloadgnutls-3e36432062f6a1a1758a13591aed7951d4081a30.tar.gz
Add patch to support Camellia, contributed by Yoshisato YANAGISAWA. Fixes #1.
See http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/2331
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 04a04056cb..e38d7197a4 100644
--- a/configure.in
+++ b/configure.in
@@ -446,6 +446,21 @@ else
fi
AM_CONDITIONAL(ENABLE_AUTHZ, test "$ac_enable_authz" != "no")
+dnl Check for Camellia support
+dnl
+AC_MSG_CHECKING([for Camellia support in libgcrypt])
+if test -n "`$LIBGCRYPT_CONFIG --algorithms|grep -i camellia`"; then
+ is_camellia_present=yes
+fi
+if test x$is_camellia_present = xyes; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(ENABLE_CAMELLIA, 1, [enable camellia block cipher])
+else
+ AC_MSG_RESULT([no])
+fi
+AM_CONDITIONAL(ENABLE_CAMELLIA, test "$is_camellia_present" = "yes")
+
+
AC_MSG_CHECKING([whether to disable extra PKI stuff])
AC_ARG_ENABLE(extra-pki,
AS_HELP_STRING([--disable-extra-pki],