summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2002-09-10 15:54:54 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2002-09-10 15:54:54 +0000
commitca59a02bceb071930f14d7c021cdf3a196b85b36 (patch)
tree7fa30611e148f2306c635fe49f39eb6012b0bdba /configure.in
parentc4aa270b2f6d7f53e3a7af59915c993a38218c48 (diff)
downloadgnutls-ca59a02bceb071930f14d7c021cdf3a196b85b36.tar.gz
changes for autoconf 2.50
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index ba6a591488..4af2779783 100644
--- a/configure.in
+++ b/configure.in
@@ -5,9 +5,9 @@ AC_INIT
AC_PREFIX_DEFAULT(/usr/local)
AC_CANONICAL_TARGET([])
-AC_DEFINE_UNQUOTED(T_CPU, "$target_cpu")
-AC_DEFINE_UNQUOTED(T_VENDOR, "$target_vendor")
-AC_DEFINE_UNQUOTED(T_OS, "$target_os")
+AC_DEFINE_UNQUOTED(T_CPU, "$target_cpu", [CPU name])
+AC_DEFINE_UNQUOTED(T_VENDOR, "$target_vendor", [Vendor name])
+AC_DEFINE_UNQUOTED(T_OS, "$target_os", [OS name])
dnl Gnutls Version
GNUTLS_MAJOR_VERSION=0
@@ -15,9 +15,9 @@ GNUTLS_MINOR_VERSION=5
GNUTLS_MICRO_VERSION=7
GNUTLS_VERSION=$GNUTLS_MAJOR_VERSION.$GNUTLS_MINOR_VERSION.$GNUTLS_MICRO_VERSION
-AC_DEFINE_UNQUOTED(GNUTLS_VERSION, "$GNUTLS_VERSION")
+AC_DEFINE_UNQUOTED(GNUTLS_VERSION, "$GNUTLS_VERSION", [version of gnutls])
-AM_INIT_AUTOMAKE(gnutls, $GNUTLS_VERSION)
+AM_INIT_AUTOMAKE(gnutls, $GNUTLS_VERSION, [version of gnutls])
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
@@ -105,7 +105,7 @@ test_mac(x,y,z);
return 0;
],
dnl ***** OK
-AC_DEFINE(C99_MACROS)
+AC_DEFINE(C99_MACROS, 1, [C99 macros are supported])
AC_MSG_RESULT(yes),
dnl ***** NOT FOUND
AC_MSG_RESULT(no)
@@ -124,11 +124,11 @@ if test $ac_cv_c_compiler_gnu != no; then
if test x$opt_dmalloc_mode = xyes; then
AC_CHECK_LIB( dmalloc, main)
- AC_DEFINE(USE_DMALLOC)
+ AC_DEFINE(USE_DMALLOC, 1, [enable the use of dmalloc])
else
if test x$opt_efence_mode = xyes; then
AC_CHECK_LIB( efence, main)
- AC_DEFINE(USE_EFENCE)
+ AC_DEFINE(USE_EFENCE, 1, [use electric fence])
fi
fi
@@ -176,7 +176,7 @@ AC_CHECK_TYPE(size_t,
DEFINE_SIZE_T="#include <sys/types.h>"
AC_SUBST( DEFINE_SIZE_T)
,
-AC_DEFINE(NO_SIZE_T)
+AC_DEFINE(NO_SIZE_T, 1, [no size_t type was found])
DEFINE_SIZE_T="typedef unsigned int size_t; typedef int ssize_t;"
AC_SUBST( DEFINE_SIZE_T)
,[
@@ -199,7 +199,7 @@ AC_CHECK_TYPE(time_t,
,
DEFINE_TIME_T="typedef unsigned int time_t;"
AC_SUBST( DEFINE_TIME_T)
- AC_DEFINE(NO_TIME_T),
+ AC_DEFINE(NO_TIME_T, 1, [no time_t type was found]),
[
#include <sys/time.h>
]
@@ -225,7 +225,7 @@ AM_PATH_LIBGCRYPT(1.1.8,,
***
]]))
dnl Can't disable - gnutls depends on gcrypt
-AC_DEFINE(USE_GCRYPT)
+AC_DEFINE(USE_GCRYPT, 1, [use gcrypt])
dnl MCRYPT
@@ -240,7 +240,7 @@ AC_ARG_WITH( mcrypt, [ --with-mcrypt enable libmcrypt support],
LIBS="${LIBS} ${LIBMCRYPT_LIBS}"
AC_ARG_WITH( mhash, [ --with-mhash enable libmhash support],
- [AC_CHECK_LIB(mhash, mhash_init, AC_DEFINE(USE_MHASH)
+ [AC_CHECK_LIB(mhash, mhash_init, AC_DEFINE(USE_MHASH, 1, [Whether to use mhash])
LIBS="${LIBS} -lmhash")])
AC_MSG_CHECKING([whether to check for external libraries])
@@ -267,7 +267,7 @@ AC_ARG_ENABLE( srp-authentication, [ --disable-srp-authentication disable t
)
if test x$ac_enable_srp != xno; then
AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_SRP)
+ AC_DEFINE(ENABLE_SRP, 1, [enable SRP authentication])
else
AC_MSG_RESULT(yes)
fi
@@ -278,7 +278,7 @@ AC_ARG_ENABLE( anon-authentication, [ --disable-anon-authentication disable
)
if test x$ac_enable_anon != xno; then
AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_ANON)
+ AC_DEFINE(ENABLE_ANON, 1, [enable anonymous authentication])
else
AC_MSG_RESULT(yes)
fi
@@ -290,7 +290,7 @@ AC_ARG_ENABLE( openpgp-authentication, [ --disable-openpgp-authentication disab
)
if test x$ac_enable_openpgp != xno; then
AC_MSG_RESULT(no)
- AM_PATH_LIBOPENCDK( 0.2.0, AC_DEFINE(HAVE_LIBOPENCDK),
+ AM_PATH_LIBOPENCDK( 0.2.0, AC_DEFINE(HAVE_LIBOPENCDK, 1, [have libopencdk]),
AC_MSG_WARN([[
***
*** libopencdk 0.2.0 was not found. You will not be able to use OpenPGP keys with gnutls.