summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2012-11-20 17:32:25 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2012-11-20 17:51:22 +0100
commit0e5683ada58ddb14969ea7aa3113de2f843eb38d (patch)
tree861a50bee149c03cbee249c1fe675a672744f309 /doc/Makefile.am
parent5653b4db4ee6ae5a8600ecacaedb577080dac0d4 (diff)
downloadgnutls-0e5683ada58ddb14969ea7aa3113de2f843eb38d.tar.gz
Several updates in certificate/public key printing.
* Added GNUTLS_CRT_PRINT_FULL_NUMBERS to print bignumbers in an easier to parse format. * Added gnutls_pubkey_import_x509_crq() to convert a certificate request to a public key. * Added gnutls_pubkey_print() to simplify public key printing. * certtool's pubkey-info can be combined with --load-request. * Added --numbers option to certtool which prints big numbers in an easier to parser format.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index f5d26d24c1..881b86fe1c 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1481,10 +1481,14 @@ FUNCS += functions/gnutls_pubkey_import_url
FUNCS += functions/gnutls_pubkey_import_url.short
FUNCS += functions/gnutls_pubkey_import_x509
FUNCS += functions/gnutls_pubkey_import_x509.short
+FUNCS += functions/gnutls_pubkey_import_x509_crq
+FUNCS += functions/gnutls_pubkey_import_x509_crq.short
FUNCS += functions/gnutls_pubkey_import_x509_raw
FUNCS += functions/gnutls_pubkey_import_x509_raw.short
FUNCS += functions/gnutls_pubkey_init
FUNCS += functions/gnutls_pubkey_init.short
+FUNCS += functions/gnutls_pubkey_print
+FUNCS += functions/gnutls_pubkey_print.short
FUNCS += functions/gnutls_pubkey_set_key_usage
FUNCS += functions/gnutls_pubkey_set_key_usage.short
FUNCS += functions/gnutls_pubkey_set_pin_function
@@ -2027,6 +2031,8 @@ FUNCS += functions/gnutls_x509_crt_set_key_usage
FUNCS += functions/gnutls_x509_crt_set_key_usage.short
FUNCS += functions/gnutls_x509_crt_set_pin_function
FUNCS += functions/gnutls_x509_crt_set_pin_function.short
+FUNCS += functions/gnutls_x509_crt_set_policy
+FUNCS += functions/gnutls_x509_crt_set_policy.short
FUNCS += functions/gnutls_x509_crt_set_private_key_usage_period
FUNCS += functions/gnutls_x509_crt_set_private_key_usage_period.short
FUNCS += functions/gnutls_x509_crt_set_proxy