summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-11-08 17:54:11 +0100
committerDaiki Ueno <dueno@redhat.com>2018-11-12 14:08:42 +0100
commit0a590e15e17383c5b18650465266da5f4cfd2af1 (patch)
treeca150883b7b934d4e772177f2bbbb9f3280b4918 /doc/Makefile.am
parenta5105a99f8bdc8b530ae2bf62535ce1b7ec0319c (diff)
downloadgnutls-0a590e15e17383c5b18650465266da5f4cfd2af1.tar.gz
db: introduce gnutls_db_check_entry_expire_time
This would be particularly useful when the same database is used to store long-lived TLS 1.2 session data and short-lived TLS 1.3 anti-replay entries. Note that the existing gnutls_db_check_entry doesn't fit in this use-case, as it takes gnutls_session_t as the argument. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index b939121898..bac1e5825c 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -877,6 +877,8 @@ FUNCS += functions/gnutls_crypto_register_mac
FUNCS += functions/gnutls_crypto_register_mac.short
FUNCS += functions/gnutls_db_check_entry
FUNCS += functions/gnutls_db_check_entry.short
+FUNCS += functions/gnutls_db_check_entry_expire_time
+FUNCS += functions/gnutls_db_check_entry_expire_time.short
FUNCS += functions/gnutls_db_check_entry_time
FUNCS += functions/gnutls_db_check_entry_time.short
FUNCS += functions/gnutls_db_get_default_cache_expiration