summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-10-19 17:52:48 +0200
committerDaiki Ueno <dueno@redhat.com>2018-11-12 14:08:45 +0100
commit79f2f1cf5b91491be5f0e3486c416594ec522b25 (patch)
treeeec06e9a96e5c64449e3469c477fc1d332953d12 /doc/Makefile.am
parent8ada9c280c9044644dfad1f234e3da32f0df86a0 (diff)
downloadgnutls-79f2f1cf5b91491be5f0e3486c416594ec522b25.tar.gz
TLS 1.3: implement anti-replay measure using ClientHello recording
This implements ClientHello recording outlined in section 8.2 of RFC 8446. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 64095e9b60..6d6865fce9 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -673,6 +673,14 @@ FUNCS += functions/gnutls_anon_set_server_known_dh_params
FUNCS += functions/gnutls_anon_set_server_known_dh_params.short
FUNCS += functions/gnutls_anon_set_server_params_function
FUNCS += functions/gnutls_anon_set_server_params_function.short
+FUNCS += functions/gnutls_anti_replay_deinit
+FUNCS += functions/gnutls_anti_replay_deinit.short
+FUNCS += functions/gnutls_anti_replay_enable
+FUNCS += functions/gnutls_anti_replay_enable.short
+FUNCS += functions/gnutls_anti_replay_init
+FUNCS += functions/gnutls_anti_replay_init.short
+FUNCS += functions/gnutls_anti_replay_set_window
+FUNCS += functions/gnutls_anti_replay_set_window.short
FUNCS += functions/gnutls_auth_client_get_type
FUNCS += functions/gnutls_auth_client_get_type.short
FUNCS += functions/gnutls_auth_get_type