summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2016-10-21 17:56:04 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2018-06-23 12:20:16 +0300
commit9a8ae7b205279bd8e6d2c34bdd45750bb294df7e (patch)
tree71a25080b83134df6c3abdfebeacc14a98c7db33 /doc/Makefile.am
parent6b8051aeeb74efc28eadb344783ab0e79963198a (diff)
downloadgnutls-9a8ae7b205279bd8e6d2c34bdd45750bb294df7e.tar.gz
Add support for importing/exporting GOST private keys
Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 68a2702227..ed6ee8371c 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1568,6 +1568,8 @@ FUNCS += functions/gnutls_privkey_export_ecc_raw
FUNCS += functions/gnutls_privkey_export_ecc_raw.short
FUNCS += functions/gnutls_privkey_export_ecc_raw2
FUNCS += functions/gnutls_privkey_export_ecc_raw2.short
+FUNCS += functions/gnutls_privkey_export_gost_raw2
+FUNCS += functions/gnutls_privkey_export_gost_raw2.short
FUNCS += functions/gnutls_privkey_export_openpgp
FUNCS += functions/gnutls_privkey_export_openpgp.short
FUNCS += functions/gnutls_privkey_export_pkcs11
@@ -1602,6 +1604,8 @@ FUNCS += functions/gnutls_privkey_import_ext3
FUNCS += functions/gnutls_privkey_import_ext3.short
FUNCS += functions/gnutls_privkey_import_ext4
FUNCS += functions/gnutls_privkey_import_ext4.short
+FUNCS += functions/gnutls_privkey_import_gost_raw
+FUNCS += functions/gnutls_privkey_import_gost_raw.short
FUNCS += functions/gnutls_privkey_import_openpgp
FUNCS += functions/gnutls_privkey_import_openpgp.short
FUNCS += functions/gnutls_privkey_import_openpgp_raw
@@ -2676,6 +2680,8 @@ FUNCS += functions/gnutls_x509_privkey_export_dsa_raw
FUNCS += functions/gnutls_x509_privkey_export_dsa_raw.short
FUNCS += functions/gnutls_x509_privkey_export_ecc_raw
FUNCS += functions/gnutls_x509_privkey_export_ecc_raw.short
+FUNCS += functions/gnutls_x509_privkey_export_gost_raw
+FUNCS += functions/gnutls_x509_privkey_export_gost_raw.short
FUNCS += functions/gnutls_x509_privkey_export_pkcs8
FUNCS += functions/gnutls_x509_privkey_export_pkcs8.short
FUNCS += functions/gnutls_x509_privkey_export_rsa_raw
@@ -2706,6 +2712,8 @@ FUNCS += functions/gnutls_x509_privkey_import_dsa_raw
FUNCS += functions/gnutls_x509_privkey_import_dsa_raw.short
FUNCS += functions/gnutls_x509_privkey_import_ecc_raw
FUNCS += functions/gnutls_x509_privkey_import_ecc_raw.short
+FUNCS += functions/gnutls_x509_privkey_import_gost_raw
+FUNCS += functions/gnutls_x509_privkey_import_gost_raw.short
FUNCS += functions/gnutls_x509_privkey_import_openssl
FUNCS += functions/gnutls_x509_privkey_import_openssl.short
FUNCS += functions/gnutls_x509_privkey_import_pkcs8