summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-09-25 13:06:57 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-09-26 12:43:18 +0200
commitb52735336857be24206e062b0a00501b1f0c597d (patch)
tree2a91be37a073422e87e3e83a36925ecbaef9e814 /doc/Makefile.am
parent7a2f81e178ee9b29090a9cac286f38e9996a389d (diff)
downloadgnutls-b52735336857be24206e062b0a00501b1f0c597d.tar.gz
manpage generation: cleanup
Recognize parameters of the form unsigned char name[8], and do not print obscure warnings. Furthermore gdoc will fail when a function parameter is not described or when no function is found. This addresses the generation of undetected errors in generated manpages. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am26
1 files changed, 13 insertions, 13 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 782b3cf55f..1e72f63adb 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -225,7 +225,7 @@ gnutls-api.texi: $(top_srcdir)/lib/includes/gnutls/gnutls.h.in
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -236,7 +236,7 @@ socket-api.texi: $(top_srcdir)/lib/includes/gnutls/socket.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -247,7 +247,7 @@ dane-api.texi: $(top_srcdir)/libdane/includes/gnutls/dane.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -259,7 +259,7 @@ x509-api.texi: $(top_srcdir)/lib/includes/gnutls/x509.h $(top_srcdir)/lib/includ
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
rm -f $@-tmp2
@@ -271,7 +271,7 @@ pkcs12-api.texi: $(top_srcdir)/lib/includes/gnutls/pkcs12.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_X509_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_X509_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -282,7 +282,7 @@ pkcs11-api.texi: $(top_srcdir)/lib/includes/gnutls/pkcs11.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -293,7 +293,7 @@ pkcs7-api.texi: $(top_srcdir)/lib/includes/gnutls/pkcs7.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_X509_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_X509_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -304,7 +304,7 @@ tpm-api.texi: $(top_srcdir)/lib/includes/gnutls/tpm.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -316,7 +316,7 @@ abstract-api.texi: $(top_srcdir)/lib/includes/gnutls/abstract.h $(top_srcdir)/li
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
rm -f $@-headers-tmp
@@ -328,7 +328,7 @@ compat-api.texi: $(top_srcdir)/lib/includes/gnutls/compat.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -339,7 +339,7 @@ dtls-api.texi: $(top_srcdir)/lib/includes/gnutls/dtls.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -350,7 +350,7 @@ crypto-api.texi: $(top_srcdir)/lib/includes/gnutls/crypto.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@
@@ -361,7 +361,7 @@ ocsp-api.texi: $(top_srcdir)/lib/includes/gnutls/ocsp.h
echo $(ECHO_N) "Creating documentation for $$i... " && \
$(srcdir)/scripts/gdoc -texinfo \
-function $$i \
- $(C_X509_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
+ $(C_X509_SOURCE_FILES) >> $@-tmp && \
echo "ok"; \
done
mv -f $@-tmp $@