summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-06-24 17:38:56 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-06-26 11:01:19 +0300
commitde42342c24ba0d4f745a4a4ba29176bb79b1a9da (patch)
tree69b8f84da457a19398e4d43c4639e769cdc77555 /doc/Makefile.am
parent4591181a6c06465393425e51c4c68a2a1126b8e8 (diff)
downloadgnutls-de42342c24ba0d4f745a4a4ba29176bb79b1a9da.tar.gz
api: add gnutls_hmac_copy() function
Add gnutls_hmac_copy() API to duplicate MAC handler state, which is necessary for SMB3 support. Resolves: #787 Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3ab2ad0049..f5788e7618 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1113,6 +1113,8 @@ FUNCS += functions/gnutls_hex_encode2
FUNCS += functions/gnutls_hex_encode2.short
FUNCS += functions/gnutls_hmac
FUNCS += functions/gnutls_hmac.short
+FUNCS += functions/gnutls_hmac_copy
+FUNCS += functions/gnutls_hmac_copy.short
FUNCS += functions/gnutls_hmac_deinit
FUNCS += functions/gnutls_hmac_deinit.short
FUNCS += functions/gnutls_hmac_fast