summaryrefslogtreecommitdiff
path: root/doc/examples/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2008-08-28 11:32:06 +0200
committerSimon Josefsson <simon@josefsson.org>2008-08-28 11:32:06 +0200
commitf0f2e1535ff596d44aa1e8b81eb30480031cd348 (patch)
treeb49cd46a3dae1472dc80315a7ecb285c4413c08f /doc/examples/Makefile.am
parent17d9e0273dcd6e699e3b81cfbfd24af22aeb6412 (diff)
downloadgnutls-f0f2e1535ff596d44aa1e8b81eb30480031cd348.tar.gz
Make disable-extra-pki work better.
Diffstat (limited to 'doc/examples/Makefile.am')
-rw-r--r--doc/examples/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am
index df1e89158f..df39364b03 100644
--- a/doc/examples/Makefile.am
+++ b/doc/examples/Makefile.am
@@ -32,8 +32,11 @@ CXX_LDADD = $(LDADD) \
../../lib/libgnutlsxx.la
noinst_PROGRAMS = ex-client2 ex-client-resume
-noinst_PROGRAMS += ex-cert-select ex-crq
-noinst_PROGRAMS += ex-serv1 ex-serv-export
+noinst_PROGRAMS += ex-cert-select
+
+if ENABLE_PKI
+noinst_PROGRAMS += ex-crq ex-serv1 ex-serv-export
+endif
if ENABLE_CXX
ex_cxx_SOURCES = ex-cxx.cpp
@@ -51,7 +54,10 @@ noinst_PROGRAMS += ex-serv-pgp
endif
if ENABLE_PSK
-noinst_PROGRAMS += ex-client-psk ex-serv-psk
+noinst_PROGRAMS += ex-client-psk
+if ENABLE_PKI
+noinst_PROGRAMS += ex-serv-psk
+endif
endif
if ENABLE_SRP