summaryrefslogtreecommitdiff
path: root/doc/manpages/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2020-02-19 14:35:04 +0100
committerDaiki Ueno <ueno@gnu.org>2020-11-19 18:18:38 +0100
commite3d6a62938a5a53b89585ace73a13b0556f176a4 (patch)
tree85f9f33cafc7c19d5acad883b0b4a9ef17aa14b5 /doc/manpages/Makefile.am
parent9f5dcddcaa6e89c3d0f9446fb7f2733f2933c3d9 (diff)
downloadgnutls-e3d6a62938a5a53b89585ace73a13b0556f176a4.tar.gz
handshake: add functions to read/write handshake messages directly
This adds a couple of functions, gnutls_handshake_set_read_function() and gnutls_handshake_write(), to allow QUIC implementations to directly interact with the TLS state machine. Signed-off-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'doc/manpages/Makefile.am')
-rw-r--r--doc/manpages/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/manpages/Makefile.am b/doc/manpages/Makefile.am
index 21621af9d7..2ecd7389b9 100644
--- a/doc/manpages/Makefile.am
+++ b/doc/manpages/Makefile.am
@@ -344,7 +344,9 @@ APIMANS += gnutls_handshake_set_max_packet_length.3
APIMANS += gnutls_handshake_set_post_client_hello_function.3
APIMANS += gnutls_handshake_set_private_extensions.3
APIMANS += gnutls_handshake_set_random.3
+APIMANS += gnutls_handshake_set_read_function.3
APIMANS += gnutls_handshake_set_timeout.3
+APIMANS += gnutls_handshake_write.3
APIMANS += gnutls_hash.3
APIMANS += gnutls_hash_copy.3
APIMANS += gnutls_hash_deinit.3