summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2011-04-17 12:13:46 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2011-04-17 23:46:30 +0200
commit61d8cae724446a5f4531d20c285e186b9ba45b6d (patch)
tree88cf60c96bbb0e207dd122b9e45e63aecad3dae8 /lib/Makefile.am
parentb4fb5cc26affff88970954b223215edb8df56e84 (diff)
downloadgnutls-61d8cae724446a5f4531d20c285e186b9ba45b6d.tar.gz
Combined external abstract API with internal usage of gnutls_cert.
This results to a gnutls_pcert_st struct exported in abstract.h. This change will allow a certificate retrieval callback that does not require gnutls to decode or encode the provided certificate.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 7afe69029a..bb5975cd6f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -72,7 +72,7 @@ COBJECTS = gnutls_record.c gnutls_compress.c debug.c gnutls_cipher.c \
gnutls_dh_primes.c gnutls_alert.c system.c \
gnutls_str.c gnutls_state.c gnutls_x509.c gnutls_rsa_export.c \
gnutls_helper.c gnutls_supplemental.c crypto.c random.c \
- crypto-api.c gnutls_privkey.c \
+ crypto-api.c gnutls_privkey.c gnutls_pcert.c \
pkcs11.c pkcs11_privkey.c gnutls_pubkey.c pkcs11_write.c locks.c \
pkcs11_secret.c hash.c gnutls_dtls.c system_override.c
@@ -89,7 +89,7 @@ HFILES = abstract_int.h debug.h gnutls_compress.h gnutls_cipher.h \
gnutls_dh.h gnutls_kx.h gnutls_hash_int.h gnutls_cipher_int.h \
gnutls_db.h gnutls_auth.h gnutls_extensions.h \
x509_b64.h gnutls_v2_compat.h gnutls_datum.h \
- gnutls_mpi.h gnutls_pk.h gnutls_record.h gnutls_cert.h \
+ gnutls_mpi.h gnutls_pk.h gnutls_record.h \
gnutls_constate.h gnutls_global.h gnutls_sig.h gnutls_mem.h \
gnutls_session_pack.h gnutls_str.h \
gnutls_state.h gnutls_x509.h \