summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos <nmav@crystal.(none)>2008-01-13 15:21:24 +0200
committerNikos <nmav@crystal.(none)>2008-01-13 15:21:24 +0200
commita0b2d269d69a25b2611380c85377197d03092283 (patch)
tree0ae919209178f08a82a5b1818b6c71e9ff07598d /lib/Makefile.am
parenta3e4759117cee5d756475215437a440dc12fcc6c (diff)
downloadgnutls-a0b2d269d69a25b2611380c85377197d03092283.tar.gz
merged the openpgp branch to head\!
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 62351ecadb..28a3d3dd4d 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -25,16 +25,25 @@ if ENABLE_MINITASN1
SUBDIRS += minitasn1
endif
+
localedir = $(datadir)/locale
AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" \
-I$(top_srcdir)/lgl -I$(top_builddir)/lgl \
-I$(top_srcdir)/includes -I../includes \
-I$(srcdir)/x509 \
- -I$(top_srcdir)/libextra -I$(top_srcdir)/libextra/openpgp/ \
- -I$(top_srcdir)/libextra/opencdk \
+ -I$(top_srcdir)/libextra -I$(top_srcdir)/lib/openpgp/ \
+ -I$(top_srcdir)/lib/opencdk \
$(LIBOPENCDK_CFLAGS) $(LIBGCRYPT_CFLAGS)
+if ENABLE_OPENPGP
+if ENABLE_INCLUDED_OPENCDK
+SUBDIRS += opencdk
+AM_CPPFLAGS += -I$(srcdir)/opencdk
+endif
+SUBDIRS += openpgp
+endif
+
if ENABLE_MINITASN1
AM_CPPFLAGS += -I$(srcdir)/minitasn1
else
@@ -75,7 +84,7 @@ COBJECTS = gnutls_record.c gnutls_compress.c debug.c gnutls_cipher.c \
ext_max_record.c gnutls_alert.c gnutls_str.c gnutls_state.c \
gnutls_x509.c ext_cert_type.c gnutls_rsa_export.c \
auth_rsa_export.c ext_server_name.c auth_dh_common.c \
- gnutls_helper.c ext_inner_application.c gnutls_extra_hooks.c \
+ gnutls_helper.c ext_inner_application.c \
gnutls_supplemental.c
if ENABLE_OPRFI
@@ -96,7 +105,7 @@ HFILES = debug.h gnutls_compress.h defines.h gnutls_cipher.h \
gnutls_rsa_export.h ext_server_name.h auth_dh_common.h \
ext_srp.h gnutls_srp.h auth_srp.h auth_srp_passwd.h \
gnutls_helper.h auth_psk.h auth_psk_passwd.h \
- ext_inner_application.h gnutls_extra_hooks.h \
+ ext_inner_application.h \
gnutls_supplemental.h ext_oprfi.h
# Separate so we can create the documentation
@@ -110,6 +119,16 @@ libgnutls_la_LDFLAGS = -no-undefined \
libgnutls_la_LIBADD = ../lgl/liblgnu.la x509/libgnutls_x509.la \
@LTLIBZ@ $(LIBGCRYPT_LIBS) @LTLIBINTL@
+if ENABLE_OPENPGP
+libgnutls_la_SOURCES += gnutls_openpgp.c
+libgnutls_la_LIBADD += openpgp/libgnutls_openpgp.la
+if ENABLE_INCLUDED_OPENCDK
+libgnutls_la_LIBADD += opencdk/libminiopencdk.la
+else
+libgnutls_la_LDFLAGS += $(LTLIBOPENCDK)
+endif
+endif
+
if HAVE_LD_VERSION_SCRIPT
libgnutls_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libgnutls.vers
endif