summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2017-09-20 09:46:34 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-02-19 15:29:34 +0100
commit56f3f7f8c381f0556d364cb0fc6e518f55b16361 (patch)
treefd1500ebd9d8d855a18462563ecfa0c2cc8a98d8 /lib/Makefile.am
parent79fd8c3917110fa2beeb57ff5e51775d313a93f7 (diff)
downloadgnutls-56f3f7f8c381f0556d364cb0fc6e518f55b16361.tar.gz
extv: introduced a low-level extension parsing code
This will simplify the parsing and handling of extensions throughout the TLS 1.3 message contents. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e6ca91a946..e8e30561df 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -79,7 +79,7 @@ COBJECTS = range.c record.c compress.c debug.c cipher.c gthreads.h \
safe-memfuncs.c system/inet_pton.c atfork.c atfork.h randomart.c \
system-keys.h urls.c urls.h prf.c auto-verify.c dh-session.c \
cert-session.c handshake-checks.c dtls-sw.c dh-primes.c openpgp_compat.c \
- crypto-selftests.c crypto-selftests-pk.c secrets.c
+ crypto-selftests.c crypto-selftests-pk.c secrets.c extv.c extv.h
if WINDOWS
COBJECTS += system/keys-win.c