summaryrefslogtreecommitdiff
path: root/libdane/Makefile.am
diff options
context:
space:
mode:
authorJaak Ristioja <jaak.ristioja@cyber.ee>2013-01-29 10:48:14 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-02-10 11:31:04 +0100
commit857b78842e7b4d0bc02869e21fa9da967df7bc6c (patch)
tree3dea617f0b6076abb7c4e348f24881e73104d93f /libdane/Makefile.am
parenta67776377c7da843087c2700deff91e97fa390db (diff)
downloadgnutls-857b78842e7b4d0bc02869e21fa9da967df7bc6c.tar.gz
Prevent libdane pkgconfig stuff from being installed if libdane support is disabled.
Diffstat (limited to 'libdane/Makefile.am')
-rw-r--r--libdane/Makefile.am19
1 files changed, 7 insertions, 12 deletions
diff --git a/libdane/Makefile.am b/libdane/Makefile.am
index d880cc8aaa..debf502def 100644
--- a/libdane/Makefile.am
+++ b/libdane/Makefile.am
@@ -32,13 +32,8 @@ AM_CPPFLAGS = \
SUBDIRS = includes
-defexecdir = $(bindir)
-defexec_DATA =
-
-
libgnutls_dane_la_LDFLAGS = -no-undefined
-if ENABLE_DANE
lib_LTLIBRARIES = libgnutls-dane.la
libgnutls_dane_la_SOURCES = dane.c dane-params.c errors.c libdane.map
@@ -56,16 +51,16 @@ else
libgnutls_dane_la_LDFLAGS += -export-symbols-regex '^(dane).*'
endif
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gnutls-dane.pc
+DISTCLEANFILES = $(pkgconfig_DATA)
+
if HAVE_LD_OUTPUT_DEF
libgnutls_dane_la_LDFLAGS += \
-Wl,--output-def,libgnutls-dane-$(DLL_VERSION).def
libgnutls_dane-$(DLL_VERSION).def: libgnutls-dane.la
-defexec_DATA += libgnutls-dane-$(DLL_VERSION).def
-endif
-endif
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gnutls-dane.pc
-DISTCLEANFILES = $(pkgconfig_DATA)
+defexecdir = $(bindir)
+defexec_DATA = libgnutls-dane-$(DLL_VERSION).def
DISTCLEANFILES += $(defexec_DATA)
+endif