summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2004-04-14 12:26:17 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2004-04-14 12:26:17 +0000
commit6338e1ed1eb49472fb5a8b7f9c3f84f3f49474c6 (patch)
tree5aeb18db65b702a58a3aadcdd31193b6b79ce25a /src/Makefile.am
parent7f14348adbc7efcf14bf4ae237d7b169c5cd5131 (diff)
downloadgnutls-6338e1ed1eb49472fb5a8b7f9c3f84f3f49474c6.tar.gz
certtool will use the system's libcfg if available.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 81309b2f23..2c35010ea1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,11 +22,17 @@ noinst_PROGRAMS = retcodes
retcodes_SOURCES = retcodes.c
retcodes_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS)
+if HAVE_LIBCFG
+certtool_SOURCES = certtool-gaa.c certtool.c prime.c getpass.c certtool-cfg.c
+certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS) -lcfg+
+else
certtool_SOURCES = certtool-gaa.c certtool.c prime.c getpass.c certtool-cfg.c \
cfg/cfg+.c cfg/cfgfile.c cfg/cmdline.c cfg/parse.c cfg/props.c \
cfg/shared.c cfg/platon/str/dynfgets.c cfg/platon/str/strctype.c \
cfg/platon/str/strdyn.c cfg/platon/str/strplus.c
certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS)
+endif
+
crypt-gaa.c: crypt.gaa