summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2007-02-13 09:51:51 +0000
committerSimon Josefsson <simon@josefsson.org>2007-02-13 09:51:51 +0000
commitf4693158762abe80d6274ee65eea5aa9671e5330 (patch)
treefca3ef7080104d29bddb7d391145d1391fbd36b7 /src/Makefile.am
parent73ca37b416aed1b2a8a29d3db2a81f677f413250 (diff)
downloadgnutls-f4693158762abe80d6274ee65eea5aa9671e5330.tar.gz
Make certtool conditional on ENABLE_PKI.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 450cae60b1..34e389eb78 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
## Process this file with automake to produce Makefile.in
-# Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation
+# Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007 Free Software Foundation
#
# This file is part of GNUTLS.
#
@@ -26,7 +26,10 @@ INCLUDES = -I../includes -I$(top_srcdir)/includes \
-I$(top_srcdir)/gl -I$(top_builddir)/gl \
-I$(srcdir)/cfg
-bin_PROGRAMS = gnutls-serv gnutls-cli psktool gnutls-cli-debug certtool
+bin_PROGRAMS = gnutls-serv gnutls-cli psktool gnutls-cli-debug
+if ENABLE_PKI
+bin_PROGRAMS += certtool
+endif
if ENABLE_SRP
bin_PROGRAMS += srptool
endif