summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2008-09-21 12:13:23 +0200
committerSimon Josefsson <simon@josefsson.org>2008-09-21 12:13:23 +0200
commitca6959e3ae82545f8ffd0f7a9491dabd77a873be (patch)
tree0c01cdc146c5431803a34bb1d055756bafc5151c /src/Makefile.am
parentd66ff7dbe507a2800abd1c5718fe435d9a8f37fb (diff)
downloadgnutls-ca6959e3ae82545f8ffd0f7a9491dabd77a873be.tar.gz
Use internal md5 if libgcrypt is in FIPS mode.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 25783ea53d..1e66abbb6c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,7 @@ endif
gnutls_serv_SOURCES = serv.gaa serv-gaa.h serv-gaa.c list.h serv.c \
common.h common.c select.c
-gnutls_serv_LDADD = ../lib/libgnutls.la \
+gnutls_serv_LDADD = ../lib/libgnutls.la ../libextra/libgnutls-extra.la \
$(LIBGCRYPT_LIBS) $(LIBTASN1_LIBS) ../gl/libgnu.la
if ENABLE_SRP
@@ -64,8 +64,8 @@ gnutls_cli_debug_LDADD = ../lib/libgnutls.la \
certtool_SOURCES = certtool.gaa certtool-gaa.h certtool-cfg.h \
certtool-gaa.c certtool.c prime.c certtool-cfg.c
-certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS) \
- $(LIBTASN1_LIBS) ../gl/libgnu.la @LTLIBREADLINE@
+certtool_LDADD = ../lib/libgnutls.la ../libextra/libgnutls-extra.la \
+ $(LIBGCRYPT_LIBS) $(LIBTASN1_LIBS) ../gl/libgnu.la @LTLIBREADLINE@
if HAVE_LIBCFG
certtool_LDADD += -lcfg+
else