summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2011-09-23 14:22:33 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2011-09-23 14:23:07 +0200
commit56120e2caabc4b7becbd961187a4aa92e3534215 (patch)
treebccaeb6ab40b94bd888232a40e7638df8c3a88b3 /tests/Makefile.am
parent8aae368bd1fb38e83ae2dc1de9c46e9d99252f21 (diff)
downloadgnutls-56120e2caabc4b7becbd961187a4aa92e3534215.tar.gz
Further optimizations in the compression code. Re-enabled the test program by suppressing the zlib warning.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 23c0bae0bc..08104a70bf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,7 +30,7 @@ if WANT_TEST_SUITE
SUBDIRS += suite
endif
-EXTRA_DIST = libgcrypt.supp eagain-common.h
+EXTRA_DIST = suppressions.valgrind eagain-common.h
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
AM_CPPFLAGS = \
@@ -57,16 +57,15 @@ endif
noinst_LTLIBRARIES = libutils.la
libutils_la_SOURCES = utils.h utils.c
-ctests = simple gc set_pkcs12_cred certder certuniqueid mpi \
+ctests = mini-deflate simple gc set_pkcs12_cred certder certuniqueid mpi \
certificate_set_x509_crl dn parse_ca moredn mini \
hostname-check cve-2008-4989 pkcs12_s2k chainverify crq_key_id \
x509sign-verify cve-2009-1415 cve-2009-1416 crq_apis \
init_roundtrip pkcs12_s2k_pem dn2 mini-eagain \
nul-in-x509-names x509_altname pkcs12_encode mini-x509 \
mini-x509-rehandshake rng-fork mini-eagain-dtls cipher-test \
- x509cert x509cert-tl infoaccess #gendh mini-deflate
-#gendh is out because it is too slow in valgrind and
-#mini-deflate is out because zlib has warnings in valgrind
+ x509cert x509cert-tl infoaccess #gendh
+#gendh is out because it is too slow in valgrind
if ENABLE_OPENSSL
ctests += openssl