summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2005-12-08 14:32:55 +0000
committerSimon Josefsson <simon@josefsson.org>2005-12-08 14:32:55 +0000
commitb3eb305de94fc79f9c69a91cc1f45ac86c04ec5c (patch)
treec9208b3c5a5bd114f0f7e4a18b9bbef41362967c /tests/Makefile.am
parente3a683c3eee3fe7e435d54a5c37de067da00c661 (diff)
downloadgnutls-b3eb305de94fc79f9c69a91cc1f45ac86c04ec5c.tar.gz
Support reading X.509 credentials from PKCS#12 files.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ab21e593e4..e30e91a530 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,7 +30,11 @@ EXTRA_DIST = client.p12 noclient.p12 unclient.p12
openssl_LDADD = $(LDADD) ../libextra/libgnutls-openssl.la
-ctests = simple anonself pskself openssl gc dhepskself
+ctests = simple anonself pskself openssl gc dhepskself set_pkcs12_cred
TESTS = pkcs12_neon $(ctests)
check_PROGRAMS = $(ctests)
dist_check_SCRIPTS = pkcs12_neon
+
+TESTS_ENVIRONMENT = \
+ PKCS12FILE=$(srcdir)/client.p12 \
+ PKCS12PASSWORD=foobar