summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2019-03-22 14:52:10 +0100
committerDaiki Ueno <ueno@gnu.org>2021-11-13 12:59:37 +0100
commit42bff24a6423f45bcfc2d03ed075916bfd6077be (patch)
treef26f16bd1ec8f93241c7d7f28b181bd66dbc75ee /tests/Makefile.am
parent33988a11e36705e7f376b7fa6747ad06aa673890 (diff)
downloadgnutls-42bff24a6423f45bcfc2d03ed075916bfd6077be.tar.gz
Port openconnect TPM2 code
This introduces transparent loading of TPM2 keys which are in PEM form by gnutls_privkey_import_x509_raw() and higher level functions which wrap it. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com> Co-authored-by: David Woodhouse <dwmw2@infradead.org> Co-authored-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e830291aa5..05ad97edf3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -490,6 +490,10 @@ endif
dist_check_SCRIPTS = rfc2253-escape-test.sh rsa-md5-collision/rsa-md5-collision.sh systemkey.sh
+if ENABLE_TPM2
+dist_check_SCRIPTS += tpm2.sh
+endif
+
if !WINDOWS
#