summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-25 17:08:43 +0200
committerDaiki Ueno <dueno@redhat.com>2019-05-14 06:44:38 +0200
commit2dc96e3b8d0e043bebf0815edaaa945f66ac0531 (patch)
treedf3932ecaf592291b53cb8936d23ba19f9226f50 /tests/Makefile.am
parent9509af0e791b74538de8ffa8dd0d47c05cb08eed (diff)
downloadgnutls-2dc96e3b8d0e043bebf0815edaaa945f66ac0531.tar.gz
ext/record_size_limit: distinguish sending and receiving limitstmp-record-sizes
The previous behavior was that both sending and receiving limits are negotiated to be the same value. It was problematic when: - client sends a record_size_limit with a large value in CH - server sends a record_size_limit with a smaller value in EE - client updates the limit for both sending and receiving, upon receiving EE - server sends a Certificate message larger than the limit With this patch, each peer maintains the sending / receiving limits separately so not to confuse with the contradicting settings. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 940e1ba605..eb65e94858 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -208,7 +208,8 @@ ctests += mini-record-2 simple gnutls_hmac_fast set_pkcs12_cred cert certuniquei
dss-sig-val sign-pk-api tls-session-ext-override record-pad \
tls13-server-kx-neg gnutls_ext_raw_parse_dtls key-export-pkcs8 \
null_retrieve_function tls-record-size-limit tls-crt_type-neg \
- resume-with-stek-expiration resume-with-previous-stek rawpk-api
+ resume-with-stek-expiration resume-with-previous-stek rawpk-api \
+ tls-record-size-limit-asym
if HAVE_SECCOMP_TESTS
ctests += dtls-with-seccomp tls-with-seccomp dtls-client-with-seccomp tls-client-with-seccomp