summaryrefslogtreecommitdiff
path: root/tests/cert-tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2021-11-24 18:44:13 +0100
committerDaiki Ueno <ueno@gnu.org>2021-11-27 14:46:44 +0100
commit1352385432a3a670f5211482f8de440d0c3bdb2f (patch)
tree0ed151998afba158ac141eea1611be878213b0a4 /tests/cert-tests/Makefile.am
parent8f17428b84f877bd04e03b6cccd0f4f23101ef3a (diff)
downloadgnutls-1352385432a3a670f5211482f8de440d0c3bdb2f.tar.gz
build: update to use the latest valgrind-tests module from Gnulib
This adjust the existing valgrind invocations in the test suite with: https://www.gnu.org/software/gnulib/manual/html_node/Valgrind-options.html - make --suppressions option to per directory, using AM_VALGRINDFLAGS - use LOG_VALGRIND for LOG_COMPILER - quote '$(LOG_VALGRIND)' in TESTS_ENVIRONMENT - move gl_VALGRIND_TESTS_DEFAULT_NO call before gl_INIT Signed-off-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'tests/cert-tests/Makefile.am')
-rw-r--r--tests/cert-tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/cert-tests/Makefile.am b/tests/cert-tests/Makefile.am
index fe196917bb..f1de1bef27 100644
--- a/tests/cert-tests/Makefile.am
+++ b/tests/cert-tests/Makefile.am
@@ -152,7 +152,7 @@ TESTS = $(dist_check_SCRIPTS)
# which are not trivial, and makes no point to address.
TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
LC_ALL="C" \
- VALGRIND="$(VALGRIND)" \
+ VALGRIND='$(LOG_VALGRIND)' \
LIBTOOL="$(LIBTOOL)" \
top_builddir="$(top_builddir)" \
abs_top_builddir="$(abs_top_builddir)" \
@@ -180,5 +180,8 @@ if DISABLE_BASH_TESTS
TESTS_ENVIRONMENT += DISABLE_BASH_TESTS=1
endif
+AM_VALGRINDFLAGS = --suppressions=$(srcdir)/suppressions.valgrind
+LOG_COMPILER = $(LOG_VALGRIND)
+
distclean-local:
rm -rf tmp-* *.tmp