summaryrefslogtreecommitdiff
path: root/tests/suite/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2018-11-09 07:44:02 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-11-10 07:20:16 +0100
commit5c7db52d2471d13d6c8e6c2e763d3ba2560d6cad (patch)
tree1ee88469b6907aa15b275a77d5ed306629f0298a /tests/suite/Makefile.am
parentf3da49beff97b399325f4616b6096d7bbdec268d (diff)
downloadgnutls-5c7db52d2471d13d6c8e6c2e763d3ba2560d6cad.tar.gz
tls13: use system's openssl for interop testing
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'tests/suite/Makefile.am')
-rw-r--r--tests/suite/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/suite/Makefile.am b/tests/suite/Makefile.am
index f43fe90eee..f6e413ee56 100644
--- a/tests/suite/Makefile.am
+++ b/tests/suite/Makefile.am
@@ -111,6 +111,10 @@ scripts_to_test += tls-fuzzer/tls-fuzzer-nocert-ssl3.sh
TESTS_ENVIRONMENT += ENABLE_SSL3=1
endif
+if ENABLE_TLS13_INTEROP
+scripts_to_test += testcompat-tls13-openssl.sh
+endif
+
if ENABLE_DANE
scripts_to_test += testdane.sh
endif
@@ -129,7 +133,7 @@ scripts_to_test += eagain.sh
endif
endif
-nodist_check_SCRIPTS = $(scripts_to_test) testcompat-tls13-openssl.sh
+nodist_check_SCRIPTS = $(scripts_to_test)
TESTS = $(scripts_to_test) prime-check