summaryrefslogtreecommitdiff
path: root/tests/suite/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-15 10:17:32 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-15 10:17:35 +0200
commitad6414ae364da776140af692f1c585f1ece0c85e (patch)
tree48572ece43143172a70dce69665634d5046058f4 /tests/suite/Makefile.am
parenteaa8f5f24c91877b25c444a4fbddb5b5ee30f683 (diff)
downloadgnutls-ad6414ae364da776140af692f1c585f1ece0c85e.tar.gz
tests: suite: disable any openssl cpu optimizations
This prevents from valgrind failures on softhsm usage due to any new instruction optimizations which are not supported by valgrind.
Diffstat (limited to 'tests/suite/Makefile.am')
-rw-r--r--tests/suite/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/suite/Makefile.am b/tests/suite/Makefile.am
index 43c5403526..1dab4fbd3d 100644
--- a/tests/suite/Makefile.am
+++ b/tests/suite/Makefile.am
@@ -98,7 +98,8 @@ TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
LC_ALL="C" \
VALGRIND="$(VALGRIND)" \
top_builddir="$(top_builddir)" \
- srcdir="$(srcdir)"
+ srcdir="$(srcdir)" \
+ OPENSSL_ia32cap=0x00000000
if ENABLE_NON_SUITEB_CURVES
TESTS_ENVIRONMENT += ENABLE_NON_SUITEB_CURVES=1