summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 57e42359bf..f3944b9366 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,14 @@ ACLOCAL_AMFLAGS = -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4 --ins
EXTRA_DIST = cfg.mk maint.mk CONTRIBUTING.md README.md LICENSE AUTHORS NEWS \
ChangeLog THANKS INSTALL.md symbols.last
+DISTCLEANFILES = AUTHORS
+
+AUTHORS:
+ @echo -e "The authors list is autogenerated from the git history; sorted by number of commits\n" >AUTHORS
+ @git shortlog -sen| cut -f 2 | sed 's/@/ at /g' >> AUTHORS
+ @echo -e "\n\nThe translators list is autogenerated from po file history\n" >>AUTHORS
+ @sed -n 's/.*Last-Translator: *\(.*\) *<.*/\1/p' po/*.po | sort -u >>AUTHORS
+
pic-check:
@echo "Checking for position dependent code"
readelf -d $(builddir)/lib/.libs/libgnutls.so|grep TEXTREL; if test $$? = 0;then \
@@ -169,4 +177,4 @@ dist-hook: libopts-check symbol-check
mv ChangeLog $(distdir)
touch $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info
-.PHONY: abi-check abi-dump pic-check symbol-check local-code-coverage-output files-update libopts-check
+.PHONY: abi-check abi-dump pic-check symbol-check local-code-coverage-output files-update libopts-check AUTHORS