summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a2267b8671..e81ff89709 100644
--- a/configure.ac
+++ b/configure.ac
@@ -708,11 +708,9 @@ AM_MISSING_PROG([AUTOGEN], [autogen])
included_libopts=no
if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
- AC_MSG_CHECKING([whether autogen is recent enough])
- if $PKG_CONFIG --atleast-version=41.1.16 autoopts 2>&1 >/dev/null; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
+ AC_CHECK_PROGS([autogen], [autogen])
+
+ if test -z "$autogen"; then
AC_MSG_WARN([[
***
*** autogen not found. Will not link against system libopts.
@@ -984,6 +982,7 @@ AC_CONFIG_FILES([
lib/unistring/Makefile
po/Makefile.in
src/Makefile
+ src/args-std.def
src/gl/Makefile
tests/Makefile
tests/windows/Makefile