summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index cbe16858bb..13e745f5e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,13 +358,11 @@ AC_ARG_ENABLE(full-test-suite,
AS_HELP_STRING([--disable-full-test-suite], [disable running very slow components of test suite]),
full_test_suite=$enableval, full_test_suite=yes)
-# test if we are in git master
+# test if we are in git master or in release build. In release
+# builds we do not use valgrind.
SUITE_FILE="${srcdir}/tests/suite/mini-eagain2.c"
if test "$full_test_suite" = yes && test ! -f "$SUITE_FILE";then
full_test_suite=no
-fi
-
-if test "$full_test_suite" != "yes";then
VALGRIND=""
AC_SUBST(VALGRIND, [])
opt_valgrind_tests=no