summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0e09644cc9..57a7673820 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,18 @@ if test $ac_cv_c_compiler_gnu != no; then
fi
fi
+AC_MSG_CHECKING([whether we have GNU ld or compatible])
+
+GLD=`ld --help < /dev/null 2>/dev/null | grep version-script`
+if test "$GLD"; then
+have_ld_version_script=yes
+ AC_MSG_RESULT(yes)
+else
+have_ld_version_script=no
+ AC_MSG_RESULT(no)
+fi
+
+AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
AC_MSG_RESULT([***
*** Detecting C library capabilities...