summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in150
1 files changed, 4 insertions, 146 deletions
diff --git a/configure.in b/configure.in
index 7a10dffb87..9908ffb0ac 100644
--- a/configure.in
+++ b/configure.in
@@ -74,7 +74,6 @@ AC_MSG_RESULT([***
dnl Checks for programs.
AC_PROG_CC
-AC_PROG_CXX
AC_PROG_LN_S
GTK_DOC_CHECK(1.1)
AC_PATH_PROG([GAA], [gaa])
@@ -377,146 +376,6 @@ fi
# stuff so we will print a warning.
ac_full=1
-AC_MSG_CHECKING([whether to enable Opaque PRF input support])
-AC_ARG_ENABLE(opaque-prf-input,
- AS_HELP_STRING([--enable-opaque-prf-input=DD],
- [enable Opaque PRF input using DD as extension type]),
- ac_opaque_prf_input=$enableval, ac_opaque_prf_input=no)
-if test "$ac_opaque_prf_input" != "no"; then
- if ! echo $ac_opaque_prf_input | egrep -q '^[[0-9]]+$'; then
- ac_opaque_prf_input=no
- AC_MSG_WARN([[
-*** Could not parse Opaque PRF Input extension type.
-*** Use --enable-opaque-prf-input=XX where XX is decimal, for example
-*** to use extension value 42 use --enable-opqaue-prf-input=42]])
- fi
-fi
-if test "$ac_opaque_prf_input" != "no"; then
- AC_MSG_RESULT([yes (extension value $ac_opaque_prf_input)])
- AC_DEFINE_UNQUOTED(ENABLE_OPRFI, $ac_opaque_prf_input,
- [enable Opaque PRF Input])
-else
- AC_MSG_RESULT(no)
-fi
-AM_CONDITIONAL(ENABLE_OPRFI, test "$ac_opaque_prf_input" != "no")
-
-AC_MSG_CHECKING([whether to disable SRP authentication support])
-AC_ARG_ENABLE(srp-authentication,
- AS_HELP_STRING([--disable-srp-authentication],
- [disable the SRP authentication support]),
- ac_enable_srp=no)
-if test x$ac_enable_srp != xno; then
- AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_SRP, 1, [enable SRP authentication])
-else
- ac_full=0
- AC_MSG_RESULT(yes)
-fi
-AM_CONDITIONAL(ENABLE_SRP, test "$ac_enable_srp" != "no")
-
-AC_MSG_CHECKING([whether to disable PSK authentication support])
-AC_ARG_ENABLE(psk-authentication,
- AS_HELP_STRING([--disable-psk-authentication],
- [disable the PSK authentication support]),
- ac_enable_psk=no)
-if test x$ac_enable_psk != xno; then
- AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_PSK, 1, [enable PSK authentication])
-else
- ac_full=0
- AC_MSG_RESULT(yes)
-fi
-AM_CONDITIONAL(ENABLE_PSK, test "$ac_enable_psk" != "no")
-
-AC_MSG_CHECKING([whether to disable anonymous authentication support])
-AC_ARG_ENABLE(anon-authentication,
- AS_HELP_STRING([--disable-anon-authentication],
- [disable the anonymous authentication support]),
- ac_enable_anon=no)
-if test x$ac_enable_anon != xno; then
- AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_ANON, 1, [enable anonymous authentication])
-else
- ac_full=0
- AC_MSG_RESULT(yes)
-fi
-AM_CONDITIONAL(ENABLE_ANON, test "$ac_enable_anon" != "no")
-
-# Allow disabling Camellia
-AC_ARG_ENABLE(camellia,
- AS_HELP_STRING([--disable-camellia], [disable Camellia cipher]),
- enable_camellia=$enableval, enable_camellia=no)
-AC_MSG_CHECKING([whether to disable Camellia cipher])
-if test "$enable_camellia" != "no"; then
- AC_MSG_RESULT([no])
- AC_DEFINE(ENABLE_CAMELLIA, 1, [enable camellia block cipher])
-else
- AC_MSG_RESULT([yes])
-fi
-
-AC_MSG_CHECKING([whether to disable extra PKI stuff])
-AC_ARG_ENABLE(extra-pki,
- AS_HELP_STRING([--disable-extra-pki],
- [only enable the basic PKI stuff]),
- enable_pki=$enableval, enable_pki=yes)
-if test "$enable_pki" != "yes"; then
- ac_full=0
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_PKI, 1, [whether to include all the PKCS/PKI stuff])
-fi
-AM_CONDITIONAL(ENABLE_PKI, test "$enable_pki" = "yes")
-
-ac_enable_openpgp=yes
-AC_MSG_CHECKING([whether to disable OpenPGP Certificate authentication support])
-AC_ARG_ENABLE(openpgp-authentication,
- AS_HELP_STRING([--disable-openpgp-authentication],
- [disable the OpenPGP authentication support]),
- ac_enable_openpgp=no)
-if test x$ac_enable_openpgp = xno; then
- AC_MSG_RESULT(yes)
- ac_full=0
-else
- AC_DEFINE(ENABLE_OPENPGP, 1, [use openpgp authentication])
- AC_MSG_RESULT(no)
-fi
-AM_CONDITIONAL(ENABLE_OPENPGP, test "$ac_enable_openpgp" = "yes")
-
-AC_MSG_CHECKING([whether to disable OpenSSL compatibility layer])
-AC_ARG_ENABLE(openssl-compatibility,
- AS_HELP_STRING([--disable-openssl-compatibility],
- [disable the OpenSSL compatibility support]),
- ac_enable_openssl=$withval,
- ac_enable_openssl=yes)
-if test x$ac_enable_openssl != xno; then
- AC_MSG_RESULT(no)
-else
- AC_MSG_RESULT(yes)
-fi
-
-AM_CONDITIONAL(ENABLE_OPENSSL, test "$ac_enable_openssl" = "yes")
-
-# Check for libtasn1
-AC_ARG_WITH(included-libtasn1,
- AS_HELP_STRING([--with-included-libtasn1], [use the included libtasn1]),
- included_libtasn1=$withval,
- included_libtasn1=no)
-if test "$included_libtasn1" = "no"; then
- AC_LIB_HAVE_LINKFLAGS(tasn1,, [#include <libtasn1.h>],
- [asn1_check_version (NULL)])
- if test "$ac_cv_libtasn1" != yes; then
- included_libtasn1=yes
- AC_MSG_WARN([[
-***
-*** Libtasn1 was not found. Will use the included one.
-]])
- fi
-fi
-AC_MSG_CHECKING([whether to use the included minitasn1])
-AC_MSG_RESULT($included_libtasn1)
-AM_CONDITIONAL(ENABLE_MINITASN1, test "$included_libtasn1" = "yes")
-
if test "$ac_full" != 1; then
AC_MSG_WARN([[
***
@@ -665,6 +524,9 @@ fi
AC_SUBST(AM_CFLAGS)
+AC_CONFIG_SUBDIRS([lib])
+AC_CONFIG_SUBDIRS([libextra])
+
AC_CONFIG_FILES([Makefile po/Makefile.in \
doc/Makefile doc/examples/Makefile doc/scripts/Makefile \
doc/manpages/Makefile doc/reference/Makefile doc/doxygen/Doxyfile \
@@ -677,14 +539,10 @@ AC_CONFIG_FILES([Makefile po/Makefile.in \
tests/key-id/Makefile tests/sha2/Makefile \
tests/hostname-check/Makefile \
includes/Makefile includes/gnutls/gnutls.h \
- lib/Makefile lib/minitasn1/Makefile lib/x509/Makefile \
- libextra/Makefile libextra/gl/Makefile \
- lib/openpgp/Makefile lib/opencdk/Makefile \
tests/openpgp/Makefile tests/openpgp-certs/Makefile \
src/Makefile \
src/cfg/Makefile src/cfg/platon/Makefile src/cfg/platon/str/Makefile \
- lib/gnutls.pc libextra/gnutls-extra.pc
- guile/Makefile guile/modules/Makefile
+ guile/Makefile guile/modules/Makefile \
guile/src/Makefile guile/tests/Makefile])
AC_CONFIG_FILES([guile/pre-inst-guile], [chmod +x guile/pre-inst-guile])