summaryrefslogtreecommitdiff
path: root/doc/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/examples/Makefile.am')
-rw-r--r--doc/examples/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am
index f5db096241..18ca3538e9 100644
--- a/doc/examples/Makefile.am
+++ b/doc/examples/Makefile.am
@@ -28,8 +28,20 @@ LDADD = libexamples.la \
../../libextra/libgnutls-extra.la \
../../gl/libgnu.la
+CXX_LDADD = libexamples.la \
+ ../../gl/libgnu.la \
+ ../../lib/libgnutls.la \
+ ../../lib/libgnutlsxx.la \
+ ../../libextra/libgnutls-extra.la
+
noinst_PROGRAMS = ex-cert-select ex-client2 ex-client-resume \
- ex-crq ex-serv1 ex-serv-export
+ ex-crq ex-serv1 ex-serv-export
+
+if ENABLE_CXX
+excxx_SOURCES = ex-cxx.cpp
+excxx_LDADD = $(CXX_LDADD)
+noinst_PROGRAMS += excxx
+endif
if ENABLE_ANON
noinst_PROGRAMS += ex-client1 ex-serv-anon