summaryrefslogtreecommitdiff
path: root/gl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index de057a7df3..9ebe35823a 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -10,7 +10,7 @@
# Generated by gnulib-tool.
#
# Invoked as: gnulib-tool --import
-# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --libtool error getline getpass-gnu gettext minmax progname stdbool
+# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --libtool alloca-opt error getline getpass-gnu gettext minmax progname snprintf stdbool vasnprintf xsize
AUTOMAKE_OPTIONS = 1.8 gnits
@@ -25,6 +25,17 @@ MOSTLYCLEANFILES =
CLEANFILES =
DISTCLEANFILES =
MAINTAINERCLEANFILES =
+BUILT_SOURCES += $(ALLOCA_H)
+EXTRA_DIST += alloca_.h
+
+# We need the following in order to create an <alloca.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(libgnu_la_OBJECTS): $(ALLOCA_H)
+alloca.h: alloca_.h
+ cp $(srcdir)/alloca_.h $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += alloca.h alloca.h-t
+
libgnu_la_SOURCES += getline.h
EXTRA_DIST += getndelim2.h getndelim2.c
@@ -37,6 +48,8 @@ libgnu_la_SOURCES += minmax.h
libgnu_la_SOURCES += progname.h progname.c
+libgnu_la_SOURCES += snprintf.h
+
BUILT_SOURCES += $(STDBOOL_H)
EXTRA_DIST += stdbool_.h
@@ -48,5 +61,9 @@ stdbool.h: stdbool_.h
mv $@-t $@
MOSTLYCLEANFILES += stdbool.h stdbool.h-t
+libgnu_la_SOURCES += printf-args.h printf-parse.h vasnprintf.h
+
+libgnu_la_SOURCES += xsize.h
+
# Makefile.am ends here