summaryrefslogtreecommitdiff
path: root/gl/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gl/tests/Makefile.am')
-rw-r--r--gl/tests/Makefile.am33
1 files changed, 5 insertions, 28 deletions
diff --git a/gl/tests/Makefile.am b/gl/tests/Makefile.am
index 703b7b45d5..4d0a31733c 100644
--- a/gl/tests/Makefile.am
+++ b/gl/tests/Makefile.am
@@ -10,7 +10,7 @@
#
# Generated by gnulib-tool.
-AUTOMAKE_OPTIONS = 1.5 foreign subdir-objects
+AUTOMAKE_OPTIONS = 1.5 foreign
SUBDIRS = .
TESTS =
@@ -267,7 +267,7 @@ EXTRA_DIST += signature.h test-gettimeofday.c
TESTS += test-intprops
check_PROGRAMS += test-intprops
-EXTRA_DIST += test-intprops.c macros.h
+EXTRA_DIST += test-intprops.c
## end gnulib module intprops-tests
@@ -321,15 +321,6 @@ EXTRA_DIST += test-inttypes.c
## end gnulib module inttypes-tests
-## begin gnulib module lock-tests
-
-TESTS += test-lock
-check_PROGRAMS += test-lock
-test_lock_LDADD = $(LDADD) @LIBMULTITHREAD@ @YIELD_LIB@
-EXTRA_DIST += test-lock.c
-
-## end gnulib module lock-tests
-
## begin gnulib module memchr-tests
TESTS += test-memchr
@@ -428,14 +419,6 @@ EXTRA_DIST += test-strerror.c signature.h macros.h
## end gnulib module strerror-tests
-## begin gnulib module strerror_r-posix-tests
-
-TESTS += test-strerror_r
-check_PROGRAMS += test-strerror_r
-EXTRA_DIST += test-strerror_r.c signature.h macros.h
-
-## end gnulib module strerror_r-posix-tests
-
## begin gnulib module string-tests
TESTS += test-string
@@ -492,12 +475,6 @@ EXTRA_DIST += test-sys_uio.c
## end gnulib module sys_uio-tests
-## begin gnulib module thread
-
-libtests_a_SOURCES += glthread/thread.h glthread/thread.c
-
-## end gnulib module thread
-
## begin gnulib module time-tests
TESTS += test-time
@@ -594,11 +571,11 @@ EXTRA_DIST += test-wchar.c
## end gnulib module wchar-tests
-## begin gnulib module yield
+## begin gnulib module dummy
-libtests_a_SOURCES += glthread/yield.h
+libtests_a_SOURCES += dummy.c
-## end gnulib module yield
+## end gnulib module dummy
# Clean up after Solaris cc.
clean-local: