summaryrefslogtreecommitdiff
path: root/guile/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'guile/src/Makefile.am')
-rw-r--r--guile/src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/guile/src/Makefile.am b/guile/src/Makefile.am
index 79c6eed55f..a960c66af1 100644
--- a/guile/src/Makefile.am
+++ b/guile/src/Makefile.am
@@ -54,6 +54,14 @@ libguile_gnutls_extra_v_0_la_LDFLAGS = \
AM_CPPFLAGS = -I$(builddir)
+if HAVE_GCC
+
+# Generated `.x' files and Guile's `scm_c_define_gsubr ()' require
+# `-Wno-strict-prototypes'.
+libguile_gnutls_v_0_la_CFLAGS += -Wno-strict-prototypes
+libguile_gnutls_extra_v_0_la_CFLAGS += -Wno-strict-prototypes
+
+endif
enums.h: $(srcdir)/make-enum-header.scm
$(GUILE_FOR_BUILD) $^ > $@