summaryrefslogtreecommitdiff
path: root/lgl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lgl/Makefile.am')
-rw-r--r--lgl/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lgl/Makefile.am b/lgl/Makefile.am
index c880187d89..a143df0719 100644
--- a/lgl/Makefile.am
+++ b/lgl/Makefile.am
@@ -641,6 +641,10 @@ wchar.h: wchar_.h
sed -e 's/@''INCLUDE_NEXT''@/$(INCLUDE_NEXT)/g' \
-e 's|@''NEXT_WCHAR_H''@|$(NEXT_WCHAR_H)|g' \
-e 's/@''HAVE_WCHAR_H''@/$(HAVE_WCHAR_H)/g' \
+ -e 's|@''GNULIB_WCWIDTH''@|$(GNULIB_WCWIDTH)|g' \
+ -e 's|@''HAVE_DECL_WCWIDTH''@|$(HAVE_DECL_WCWIDTH)|g' \
+ -e 's|@''REPLACE_WCWIDTH''@|$(REPLACE_WCWIDTH)|g' \
+ -e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \
< $(srcdir)/wchar_.h; \
} > $@-t
mv $@-t $@