summaryrefslogtreecommitdiff
path: root/lib/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/configure.ac')
-rw-r--r--lib/configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/configure.ac b/lib/configure.ac
index 1ef9d970d8..fdb3857f90 100644
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -79,6 +79,23 @@ else
AC_MSG_RESULT(no)
fi
+AC_ARG_WITH(pakchois, AS_HELP_STRING([--without-pakchois],
+ [disable pakchois PKCS11 support]),
+ ac_pakchois=$withval, ac_pakchois=yes)
+AC_MSG_CHECKING([whether to include pakchois PKCS11 support])
+if test x$ac_pakchois != xno; then
+ AC_MSG_RESULT(yes)
+ AC_LIB_HAVE_LINKFLAGS(pakchois,, [#include <pakchois/pakchois.h>], [pakchois_module_load(0,0);])
+ if test "$ac_cv_libpakchois" != yes; then
+ AC_MSG_WARN(
+***
+*** Pakchois was not found. You will not be able to use PKCS11 support.)
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+AM_CONDITIONAL(ENABLE_PKCS11, test "$ac_cv_libpakchois" = "yes")
+
lgl_INIT
LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS"