summaryrefslogtreecommitdiff
path: root/lib/nettle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/nettle/Makefile.am')
-rw-r--r--lib/nettle/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/nettle/Makefile.am b/lib/nettle/Makefile.am
index 936f20c6ad..aae87e0902 100644
--- a/lib/nettle/Makefile.am
+++ b/lib/nettle/Makefile.am
@@ -49,7 +49,11 @@ libcrypto_la_SOURCES = pk.c mpi.c mac.c cipher.c init.c \
int/block8.h backport/block-internal.h
if WINDOWS
+if HAVE_BCRYPT
+libcrypto_la_SOURCES += sysrng-bcrypt.c
+else
libcrypto_la_SOURCES += sysrng-windows.c
+endif
else
if HAVE_GETENTROPY
libcrypto_la_SOURCES += sysrng-getentropy.c