summaryrefslogtreecommitdiff
path: root/lib/nettle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/nettle/Makefile.am')
-rw-r--r--lib/nettle/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/nettle/Makefile.am b/lib/nettle/Makefile.am
index 8c1a2d17ee..e4d9ad64ef 100644
--- a/lib/nettle/Makefile.am
+++ b/lib/nettle/Makefile.am
@@ -86,14 +86,19 @@ libcrypto_la_SOURCES += \
gost/pbkdf2-hmac-gosthash94.c gost/pbkdf2-hmac-streebog.c \
gost/pbkdf2-gost.h
+if NEED_GOSTDSA
libcrypto_la_SOURCES += \
gost/nettle-internal.h \
gost/ecc-gost256cpa.c gost/ecc-gost256cpa-32.h gost/ecc-gost256cpa-64.h\
gost/ecc-gost512a.c gost/ecc-gost512a-32.h gost/ecc-gost512a-64.h \
gost/ecc-internal.h gost/gmp-glue.h \
gost/ecc-gostdsa-sign.c gost/ecc-gostdsa-verify.c \
- gost/gostdsa-mask.c gost/gostdsa-sign.c gost/gostdsa-verify.c gost/gostdsa-vko.c \
+ gost/gostdsa-sign.c gost/gostdsa-verify.c \
gost/gostdsa.h gost/ecc-gost-curve.h gost/ecc-gost-hash.c
+endif
+
+libcrypto_la_SOURCES += \
+ gost/gostdsa-mask.c gost/gostdsa-vko.c gost/gostdsa2.h
libcrypto_la_SOURCES += gost_keywrap.c
endif