summaryrefslogtreecommitdiff
path: root/tests/cert-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/cert-tests/Makefile.am')
-rw-r--r--tests/cert-tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/cert-tests/Makefile.am b/tests/cert-tests/Makefile.am
index fe196917bb..f1de1bef27 100644
--- a/tests/cert-tests/Makefile.am
+++ b/tests/cert-tests/Makefile.am
@@ -152,7 +152,7 @@ TESTS = $(dist_check_SCRIPTS)
# which are not trivial, and makes no point to address.
TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
LC_ALL="C" \
- VALGRIND="$(VALGRIND)" \
+ VALGRIND='$(LOG_VALGRIND)' \
LIBTOOL="$(LIBTOOL)" \
top_builddir="$(top_builddir)" \
abs_top_builddir="$(abs_top_builddir)" \
@@ -180,5 +180,8 @@ if DISABLE_BASH_TESTS
TESTS_ENVIRONMENT += DISABLE_BASH_TESTS=1
endif
+AM_VALGRINDFLAGS = --suppressions=$(srcdir)/suppressions.valgrind
+LOG_COMPILER = $(LOG_VALGRIND)
+
distclean-local:
rm -rf tmp-* *.tmp