summaryrefslogtreecommitdiff
path: root/tests/suite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/suite/Makefile.am')
-rw-r--r--tests/suite/Makefile.am24
1 files changed, 11 insertions, 13 deletions
diff --git a/tests/suite/Makefile.am b/tests/suite/Makefile.am
index c6d60f43d2..b4b01c73db 100644
--- a/tests/suite/Makefile.am
+++ b/tests/suite/Makefile.am
@@ -83,18 +83,15 @@ nodist_libecore_la_SOURCES = ecore/src/lib/ecore_anim.c \
ecore/src/lib/eina_ustringshare.c ecore/src/lib/eina_value.c
-
-nodist_check_SCRIPTS = eagain testsrn chain.sh invalid-cert testrandom \
- testpkcs11.sh testpkcs11.pkcs15 testpkcs11.softhsm testpkcs11.sc-hsm \
- testrng testcompat-main-polarssl testcompat-main-openssl testcompat-common \
- testcompat-polarssl testcompat-openssl
-
-TESTS = test-ciphersuite-names.sh eagain testsrn chain.sh invalid-cert \
- testrng testcompat-openssl testcompat-polarssl
+EXTRA_DIST += testcompat-main-polarssl testcompat-main-openssl testcompat-common \
+ testpkcs11.pkcs15 testpkcs11.softhsm testpkcs11.sc-hsm
+nodist_check_SCRIPTS = testsrn.sh chain.sh invalid-cert.sh \
+ testpkcs11.sh testrng.sh testcompat-polarssl.sh testcompat-openssl.sh \
+ testrandom.sh
if ENABLE_PKCS11
check_PROGRAMS += pkcs11-chainverify pkcs11-get-issuer pkcs11-is-known pkcs11-combo pkcs11-privkey
-TESTS += testpkcs11.sh pkcs11-chainverify pkcs11-get-issuer crl-test pkcs11-is-known pkcs11-combo pkcs11-privkey
+nodist_check_SCRIPTS += testpkcs11.sh pkcs11-chainverify pkcs11-get-issuer crl-test pkcs11-is-known pkcs11-combo pkcs11-privkey
endif
TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
@@ -104,7 +101,7 @@ TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
srcdir="$(srcdir)"
if ENABLE_DANE
-TESTS += testdane
+nodist_check_SCRIPTS += testdane.sh
endif
if !MACOSX
@@ -117,14 +114,15 @@ nodist_eagain_cli_SOURCES = mini-eagain2.c
noinst_PROGRAMS = eagain-cli mini-record-timing
-TESTS += eagain
+nodist_check_SCRIPTS += eagain.sh
endif
endif
-#pkcs11-chainverify cannot run under valgrind (or hell breaks loose)
+TESTS = $(nodist_check_SCRIPTS)
-if WANT_TEST_SUITE
TEST_EXTENSIONS = .sh
+
+if WANT_TEST_SUITE
LOG_COMPILER = $(VALGRIND)
SH_LOG_COMPILER =
endif