summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2012-07-04 11:58:13 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2012-11-28 21:31:23 +0100
commitaf2e146f5f24b93322ad0112d37a8e41222c3085 (patch)
treeaa0e94914de51582e19ec7566cd5b40c88475e87 /Makefile.am
parentc9516551d29432270f5f840ef315ce34f654a62f (diff)
downloadgobject-introspection-af2e146f5f24b93322ad0112d37a8e41222c3085.tar.gz
giscanner: add AnnotationParser tests
The tests in giscanner/annotationpatters.py only test the regular expression programs used when parsing GTK-Doc comment blocks but do not test the structure of the resulting "parse tree". This patch adds 193 GTK-Doc comment blocks and the expected results AnnotationParser should return (with it's current level of understanding of GTK-Doc comment block syntax). These are compared by tests/scanner/annotationparser/test_parser.py which complains with a diff on failure. https://bugzilla.gnome.org/show_bug.cgi?id=688897
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2059b989..76837554 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,8 @@ check-local:
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
@echo "TEST: Annotation pattern programs"
$(PYTHON) $(top_srcdir)/giscanner/annotationpatterns.py
+ @echo "TEST: GTK-Doc Annotation Parser"
+ PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_parser.py
@touch $(top_builddir)/.make-check-passed
check-pyflakes: