summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2015-04-21 21:53:07 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2015-06-29 16:59:36 +0200
commit2896dc4083accd92c4b80ef4d9972c2e2009bda2 (patch)
treeb1c5387735174df1248d59738fdd664d342a4bf7 /Makefile.am
parentdea692d32ce1e5ce2f1fff27d322d34cd7841747 (diff)
downloadgobject-introspection-2896dc4083accd92c4b80ef4d9972c2e2009bda2.tar.gz
tests: Update misc/pep8.py to 1.6.2
Updated from: https://raw.githubusercontent.com/jcrocholl/pep8/1.6.2/pep8.py
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cbd57121..9ea81910 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,9 +63,9 @@ PEP8_EXCLUDES=--exclude='.svn,CVS,.bzr,.hg,.git,__pycache__,.\#*'
check-local:
@echo "TEST: PEP-8 INQUISITION"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs \
- $(PYTHON) $(top_srcdir)/misc/pep8.py --max-line-length=99 --ignore=E128 $(PEP8_EXCLUDES)
+ $(PYTHON) $(top_srcdir)/misc/pep8.py --max-line-length=99 --ignore=E128,W503 $(PEP8_EXCLUDES)
@find $(top_srcdir)/tests -name \*.py | sort | uniq | xargs \
- $(PYTHON) $(top_srcdir)/misc/pep8.py --ignore=E127,E501 $(PEP8_EXCLUDES)
+ $(PYTHON) $(top_srcdir)/misc/pep8.py --ignore=E127,E402,E501,E731 $(PEP8_EXCLUDES)
check-pyflakes:
@echo " CHECK Pyflakes"