summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2012-04-03 08:08:45 +0200
committerJohan Dahlin <jdahlin@litl.com>2012-04-05 10:23:02 -0300
commit182fdfec261f36fa095484352b9b834861036907 (patch)
tree47756b386f2eae5cf99cf345dc841606824708f7 /Makefile.am
parent5ab6a478f5fe7642090032e3345f8c884e15f5b7 (diff)
downloadgobject-introspection-182fdfec261f36fa095484352b9b834861036907.tar.gz
Now make AnnotationParser do what gobject-introspection needs it to do.
https://bugzilla.gnome.org/show_bug.cgi?id=672254
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9cc54cfb..a36c200a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,8 +61,10 @@ check-local:
pre-commit hook.\n\ncopy misc/pre-commit to .git/hooks"; false))
@test ! -d $(top_srcdir)/.git || (test -x $(top_srcdir)/.git/hooks/pre-commit || (echo -e "ERROR: pre-commit \
is not executable\n\nrun chmod +x .git/hooks/pre-commit"; false))
- @echo " PEP-8 INQUISITION"
+ @echo "TEST: PEP-8 INQUISITION"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
+ @echo "TEST: Annotation pattern programs"
+ $(PYTHON) $(top_srcdir)/giscanner/annotationpatterns.py
@touch $(top_builddir)/.make-check-passed
check-pyflakes: