summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2012-11-28 19:48:47 +0100
committerDieter Verfaillie <dieterv@optionexplicit.be>2012-11-28 21:31:23 +0100
commit1de10b1b740ae84a51c6f4e52374afdbbc10d74c (patch)
treeaac3ff7a6efd4e155d5b0a9d8348e47307619e6d /Makefile.am
parentaf2e146f5f24b93322ad0112d37a8e41222c3085 (diff)
downloadgobject-introspection-1de10b1b740ae84a51c6f4e52374afdbbc10d74c.tar.gz
giscanner: move unit tests from giscanner/annotationpatters.py...
... to tests/scanner/annotationparser/test_patterns.py because the following patch will remove giscanner/annotationpatters.py https://bugzilla.gnome.org/show_bug.cgi?id=688897
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 76837554..c4f67031 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,7 +65,7 @@ check-local:
@echo "TEST: PEP-8 INQUISITION"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
@echo "TEST: Annotation pattern programs"
- $(PYTHON) $(top_srcdir)/giscanner/annotationpatterns.py
+ PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_patterns.py
@echo "TEST: GTK-Doc Annotation Parser"
PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_parser.py
@touch $(top_builddir)/.make-check-passed