summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Feltman <sfeltman@src.gnome.org>2013-12-21 16:59:22 -0800
committerColin Walters <walters@verbum.org>2013-12-29 19:19:33 +0000
commit4e88f0eb1535cffa31d8fd15ba593ac0a09b670a (patch)
treee56a5ef23dffd8a37a64b19949ae54e027ce443b /Makefile.am
parentbeb7a5689446a9fb2ff1d9b68b113d7855fa5126 (diff)
downloadgobject-introspection-4e88f0eb1535cffa31d8fd15ba593ac0a09b670a.tar.gz
tests: Use Automake test harness instead of gtester
Switch both cmph-bdz-test and gthash_test to use the Automake test harness. Use EXTRA_PROGRAMS and EXTRA_LTLIBRARIES along with CLEANUP to allow lazy dependency evaluation of testing targets. https://bugzilla.gnome.org/show_bug.cgi?id=720713
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 18fe0913..2ec04d04 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,8 +9,10 @@ check_LTLIBRARIES =
check_PROGRAMS =
bin_PROGRAMS =
bin_SCRIPTS =
-GTESTER_PROGS =
-noinst_PROGRAMS = $(GTESTER_PROGS)
+noinst_PROGRAMS =
+EXTRA_LTLIBRARIES =
+EXTRA_PROGRAMS =
+TESTS =
include common.mk
include Makefile.introspection
@@ -59,7 +61,6 @@ EXTRA_DIST += \
PEP8_EXCLUDES=--exclude='.svn,CVS,.bzr,.hg,.git,__pycache__,.\#*'
check-local:
- gtester --verbose $(GTESTER_PROGS)
@echo "TEST: PEP-8 INQUISITION"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs \
$(PYTHON) $(top_srcdir)/misc/pep8.py --max-line-length=99 --ignore=E128 $(PEP8_EXCLUDES)