summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Feltman <sfeltman@src.gnome.org>2013-12-18 18:30:54 -0800
committerColin Walters <walters@verbum.org>2013-12-29 19:45:42 +0000
commitf27aff293b8f811dbea6311d06be42eec2d980d8 (patch)
tree35060f4dd8f651165062c14be38172de77f7e2e8 /Makefile.am
parent42bb69a6a2f12165a9758b192e80da089e00ab5c (diff)
downloadgobject-introspection-f27aff293b8f811dbea6311d06be42eec2d980d8.tar.gz
tests: Use Python unittest module parameterization for annotationparser
Add Python unittest module parameterization support to gi-tester through the use of a "TESTARGS" variable. Use the Automake test harness along with gi-tester for running the Python annotationparser tests. Add tests/scanner/annotationparser/Makefile.am and localize testing rules and EXTRA_DIST setup to this file. Specific Python tests can now be run as follows: cd tests/scanner/annotationparser make check TESTS=test_patterns.py TESTARGS=TestTagValueStability https://bugzilla.gnome.org/show_bug.cgi?id=720713
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ec04d04..1a988a5f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,10 +66,6 @@ check-local:
$(PYTHON) $(top_srcdir)/misc/pep8.py --max-line-length=99 --ignore=E128 $(PEP8_EXCLUDES)
@find $(top_srcdir)/tests -name \*.py | sort | uniq | xargs \
$(PYTHON) $(top_srcdir)/misc/pep8.py --ignore=E127,E501 $(PEP8_EXCLUDES)
- @echo "TEST: Annotation pattern programs"
- PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_patterns.py
- @echo "TEST: GTK-Doc Annotation Parser"
- PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_parser.py
check-pyflakes:
@echo " CHECK Pyflakes"