summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2008-02-10 19:19:15 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-02-10 19:19:15 +0000
commita49bf15ca083244f06601cba92f34f1d77e0f0bf (patch)
treefa1103d9ee0c7a8f890db40ff322091eff1b5d55 /Makefile.am
parente1d69db76edfffac4a214372487bd515d68b1739 (diff)
downloadgobject-introspection-a49bf15ca083244f06601cba92f34f1d77e0f0bf.tar.gz
Make 'make distcheck' work again.
2008-02-10 Johan Dahlin <johan@gnome.org> * Makefile.am: * configure.ac: * girepository/Makefile.am: Make 'make distcheck' work again. svn path=/trunk/; revision=110
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 978d2c09..189f1d72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,9 @@
## Process this file with automake to produce Makefile.in
-DIST_SUBDIRS = m4
-SUBDIRS = gidl girepository tools tests
ACLOCAL_AMFLAGS = -I m4
+SUBDIRS = gidl girepository tools tests
+DIST_SUBDIRS = m4 $(SUBDIRS)
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gobject-introspection.pc
EXTRA_DIST = $(pkgconfig_DATA)
@@ -16,7 +17,6 @@ clean-gcov:
clean-gcno:
find -name "*.gcno" -delete
-.PHONEY: gcov-all
gcov-all:
@for dir in $(GCOV_DIRS); do \
cd $(abs_srcdir)/$$dir && \
@@ -24,8 +24,7 @@ gcov-all:
gcov -f -p -o `find $(abs_builddir)/$$dir -newer $$file -name "*-$${file/.c/.gcda}" -print0 | sed -e 's/\.gcda/\.o/'` $$file > /dev/null; \
done \
done
-
-.PHONEY: coverage-report.txt
+
coverage-report.txt: clean clean-gcov all check gcov-all
@rm -f $(top_builddir)/coverage-report.txt
@echo -e "=== Coverage Report ===\n" >> $(top_builddir)/coverage-report.txt
@@ -37,6 +36,8 @@ coverage-report.txt: clean clean-gcov all check gcov-all
check-coverage: coverage-report.txt
@cat $(top_builddir)/coverage-report.txt
+.PHONEY: gcov-all coverage-report.txt
+
else
check-coverage: