summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2008-08-09 13:17:00 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-08-09 13:17:00 +0000
commit55ca12bd3905d633c871c1b73b97968c55c88d0f (patch)
tree16b3ba7e72e782f0e4fc7fe61d7eb857786c5c3f /Makefile.am
parente48a8b65b61dade42f23a3549ceb1b08afbe227b (diff)
downloadgobject-introspection-55ca12bd3905d633c871c1b73b97968c55c88d0f.tar.gz
Clean up gcov integration a bit
svn path=/trunk/; revision=342
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 16 insertions, 33 deletions
diff --git a/Makefile.am b/Makefile.am
index b761c60a..d382d24b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,47 +1,30 @@
## Process this file with automake to produce Makefile.in
-ACLOCAL_AMFLAGS = -I m4
+include $(top_srcdir)/gcov.mak
-SUBDIRS = gir girepository giscanner tools tests
-DIST_SUBDIRS = m4 $(SUBDIRS)
-man_MANS = docs/g-ir-scanner.1
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gobject-introspection-1.0.pc
-EXTRA_DIST = $(pkgconfig_DATA)
+GCOVSOURCES =
if GI_GCOV_ENABLED
GCOV_DIRS = girepository tools
-clean-gcov:
- find -name "*.gcda" -o -name "*.gcov" -delete
-
-clean-gcno:
- find -name "*.gcno" -delete
-
-gcov-all:
- @for dir in $(GCOV_DIRS); do \
- cd $(abs_srcdir)/$$dir && \
- for file in *.c; do \
- gcov -f -p -o `find $(abs_builddir)/$$dir -newer $$file -name "*-$${file/.c/.gcda}" -print0 | sed -e 's/\.gcda/\.o/'` $$file > /dev/null; \
- done \
- done
-
-coverage-report.txt: clean clean-gcov all check gcov-all
- @rm -f $(top_builddir)/coverage-report.txt
- @echo -e "=== Coverage Report ===\n" >> $(top_builddir)/coverage-report.txt
- @for dir in $(GCOV_DIRS); do \
- echo "Module '$$dir':" >> $(top_builddir)/coverage-report.txt; \
- $(MAKE) -C $$dir coverage-report; \
- done
-
check-coverage: coverage-report.txt
@cat $(top_builddir)/coverage-report.txt
-.PHONEY: gcov-all coverage-report.txt
-
else
check-coverage:
- @echo "Need to reconfigure with --enable-gcov"
+ @echo "ERROR: Need to reconfigure with --enable-gcov to run make check-coverage"
endif
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = gir girepository giscanner tools tests
+DIST_SUBDIRS = m4 $(SUBDIRS)
+
+man_MANS = docs/g-ir-scanner.1
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gobject-introspection-1.0.pc
+
+EXTRA_DIST = $(pkgconfig_DATA)
+