summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Rivera <cmr@litl.com>2009-05-20 19:29:33 -0400
committerJohan Dahlin <johan@gnome.org>2009-05-28 12:43:16 -0300
commitf941537d1c0a40f0906490ed160db6c79af572d3 (patch)
tree2fa6464c1cc2ecfaaceb974d1e143170fcf1866a /Makefile.am
parentaa94335b84d17512281ab3ed4cd20fb1fad9dcd8 (diff)
downloadgobject-introspection-f941537d1c0a40f0906490ed160db6c79af572d3.tar.gz
Fix pep8.py and its invocation.
pep8.py:input_file() normally returns the number of errors found in a given file, but it returns an empty dict if the file is excluded. Change it to return 0 instead. config.py is auto-generated with a prefix that may be longer than 80 characters. Exclude config.py in the pep8.py check. This fixes 4042.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a4de038..4bb0e244 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,6 +53,6 @@ upload-release: $(distdir).tar.gz
check-local:
@echo " PEP-8 INQUISITION"
- @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat
+ @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
@echo " CHECK Pyflakes"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pyflakes.py