summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-08-15 08:53:20 +0000
committerChristoph Reiter <reiter.christoph@gmail.com>2018-08-15 08:53:20 +0000
commit4f6a7d577e8eaf32c2fcabb954b8906c48eef773 (patch)
treec7220fa74dd0bcac258fcd20f19b99bd82b96db7 /Makefile.am
parentf2be65b417b7179f5490c0735d053bd466f7f317 (diff)
parent95ec2341a02f50ddc2013d707818fcf3738c133f (diff)
downloadgobject-introspection-4f6a7d577e8eaf32c2fcabb954b8906c48eef773.tar.gz
Merge branch 'flake8' into 'master'
tests: depend on flake8 instead of including pep8/pyflakes See merge request GNOME/gobject-introspection!58
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 4 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index e071ec25..44ed1153 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,30 +53,17 @@ EXTRA_DIST += \
$(pkgconfig_DATA) \
$(man_MANS) \
$(m4_DATA) \
- misc/pep8.py \
- misc/pyflakes.py \
misc/update-glib-annotations.py \
misc/update-gtkdoc-tests.py \
misc/verbump.py \
README.rst \
MSVC.README.rst \
meson.build \
- meson_options.txt
-
-# Default pep8.py --exclude + emacs backup files
-PEP8_EXCLUDES=--exclude='.svn,CVS,.bzr,.hg,.git,__pycache__,.\#*'
-
-check-local:
- @echo "TEST: PEP-8 INQUISITION"
- @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs \
- $(PYTHON) $(top_srcdir)/misc/pep8.py --max-line-length=99 --ignore=E128,W503 $(PEP8_EXCLUDES)
- @find $(top_srcdir)/tests -name \*.py | sort | uniq | xargs \
- $(PYTHON) $(top_srcdir)/misc/pep8.py --ignore=E127,E402,E501,E731 $(PEP8_EXCLUDES)
-
-check-pyflakes:
- @echo " CHECK Pyflakes"
- @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pyflakes.py
+ meson_options.txt \
+ .flake8
+check.quality:
+ (cd $(abs_top_srcdir) && $(PYTHON) -m flake8 --count);
# Colin's handy Makefile bits for:
# 1) stuffing tarballs with pre-generated scripts from your workstation